Android Auto won’t run on Galaxy s6

Uncategorized
Android Auto was running just fine on my Galaxy s6. Suddenly, I get a message on the phone that says "Phone system is too old, App needs Android upgrade soon". My phone is running Android v.7.0, and I’ve done all the updates that are available. It has nothing to do with the usb cable, the message appears on my phone, not on the infotainment screen of my 2018 Honda Fit. A different phone I have in the car runs AA just fine.

Sharing is caring!

Leave a Reply