Android has no ‘install’ button on apk file

Uncategorized
I have 4 absolutely new, fresh out of the box, MDE devices, all with Android 8.1.0
None of them has or needs a Google Account, so I am trying to fix this without the Google Store. On all 4 of them I allowed Chrome and ‘Files’ to install apps from unknown sources.
ONE works without issues, THREE tell me ‘can’t open file’ and are missing the ‘install’-button in the ‘Files’ app. I do have an ‘open with’ button, but when I click it it says ‘None of your apps can open this file’. I can however extract the apk-files, but that doesn’t help accomplish anything.
After downloading the apk-file in Chrome I get an ‘install’-question at the bottom, but when I click on it, it just throws me into the download-folder in which the file is and does nothing. If I click on the file it just says ‘can’t open file’.
I can’t see any differences, I did the same steps on all 4 of them, used the same wifi, the same download-source, they all have the same standard apps, the same settings – I am clueless.

I already tried completely resetting one of the devices – 3 times – but the issue persists.
Of course I also already tried to find any solution in the internet, but I can’t even find anyone who has exactly this issue.

Sharing is caring!

Leave a Reply